Luis Villa's Blog

Thu, 09 Jun 2005

22:40

So... let's play 'Luis is a journalist, who writes for a news site with a focus on small, timely articles', and see what Luis might have written about today in GNOME.

Developers discuss dependency on next version of GTK

GNOME developers today discussed whether or not the next version of GNOME (2.12, due out in September) should depend on gtk 2.8, the next version of GTK. Two main concerns appear to have been raised that might block the dependency. First, several GNOME release team members had concerns about the timeliness of the gtk release process; Mattias Clasen and Mark McLoughlin attempted to address those. That discussion appears to be ongoing. Second, there appear to be serious performance issues with gtk 2.8, because of the planned dependency on the cairo library. Tests performed by a community member (who admitted to lacking gtk expertise) suggested that some 2.8 widgets were up to 400% slower than their 2.6 counterparts. When contacted by email, gtk developers said that these performance issues were known and there were ongoing plans to address them in the three months before the release. LuisNews will keep you posted on the state of the discussion and the progress of the gtk team in resolving these issues as gtk 2.8 moves closer to release.

There, that was constructive yet critical, no?